Dobrodošli, Gost. Molim vas prijavite se ili se registrujte.
Da niste izgubili svoj aktivacioni e-mail?
Oreska - Užice
Prijavite se sa korisničkim imenom, lozinkom i dužinom sesije
 
ARHIVA
   Početna   Pomoć Pravila Pretraga Kalendar Gallery Contact Prijavljivanje Registracija  
IZBORI: NAJFORUMAŠ I NAJFORUMAŠICA GODINE
AKCIJA: SVI UŽIČANI NA JEDNOM MESTU!
Za užičke nekomercijalne organizacije i ustanove besplatno...
Stranice: [1]
  Štampaj  
This topic has not yet been rated!
You have not rated this topic. Select a rating:
Autor Tema: MikroTik Skripta -  (Pročitano 2761 puta)
blagoje
provereni korisnici
posetilac
**
Pol: Muškarac
Ime i prezime:
Blagoje Radovic
Mesto: Istočno Sarajevo
Horoskop: Ovan
Poruke: 27


« poslato: 15.05.2012. 09:50:50 »

Pozdrav,

Imam jednu skriptu koja vrši update IP adrese za Open DNS. Međutim, imam problem što je MT povezan na dva ISP-a (ADSL i wireless), tako da imam i dvije adrese na internetu! Ideja mi je da napravim dva naloga na OpenDNS i dvije skripte za update.

Povezivanje dva ISP-a je izvršeno jednostavno, imam tri LAN karte, jedna lokalna i dvije prema ISP, a default route ima dva gateway-a.

Problem je što skripta izlazi na internet "kuda hoće", tj. ne znam kako da joj kažem da ide po određenom interfejsu!

Ima li neko ideju za prepravku?

Skripta:

# DNSoMatic automatic DNS updates
# User account info of DNSoMatic (e-mail nalog na koji je otvoren Open DNS)
:global maticuser "xxxxxxx"
# User password info of DNSoMatic (password na Open DNS-u)
:global maticpass "xxxxx"
:global matichost "Office"
# No more changes need
 
:global previousIP
 
# Print values for debug
:log info "DNSoMatic: Updating dynamic IP on DNS for host $matichost"
:log info "DNSoMatic: User $maticuser y Pass $maticpass"
:log info "DNSoMatic: Last IP $previousIP"
 
# get the current IP address from the internet (in case of double-nat)
/tool fetch mode=http address="checkip.dyndns.org" src-path="/" dst-path="/dyndns.checkip.html"
:local result [/file get dyndns.checkip.html contents]
 
# parse the current IP result
:local resultLen [:len $result]
:local startLoc [:find $result ": " -1]
:set startLoc ($startLoc + 2)
:local endLoc [:find $result "" -1]
:global currentIP [:pick $result $startLoc $endLoc]
:log info "DNSoMatic: IP actual $currentIP"
 
# Touching the string passed to fetch command on "src-path" option
:local str "/nic/update?hostname=$matichost&myip=$currentIP&wildcard=NOCHG&mx=NOCHG&backmx=NOCHG"
 
:if ($currentIP != $previousIP) do={
:log info "DNSoMatic: Update need"
:set previousIP $currentIP
:log info "DNSoMatic: Sending update $currentIP"
:log info [ :put [/tool fetch host=updates.dnsomatic.com user=$maticuser password=$maticpass mode=http address="updates.dnsomatic.com" src-path=$str dst-path=$matichost]]
:log info "DNSoMatic: Host $matichost updated on DNSoMatic with IP $currentIP"
}  else={
:log info "DNSoMatic: Previous IP $previousIP and current $currentIP equal, no update need"
}
Sačuvana
Pedja
urednik
stara kajla
*****
Pol: Muškarac
Ime i prezime:
Peđa Supurović
Mesto: Užice
Lokacija: Crna dama
Država: Srbija
FaceBook: ima
Blog: ima
Horoskop: Strelac
Poruke: 12963



WWW
« Odgovor #1 poslato: 16.05.2012. 11:31:17 »

Treba da napraviš rouiranej posebno za tu konekciju tako da je uvek usmeravaš preko željenog interfejsa. U Mangle označi sa route-mark rutu (na primer po odredišnoj IP adresi a u ruting tabeli ubaci ruting pravilo sa zadatim routing-mark koje će da usmerava označene konekcije na odgovarajući gejtvej.


Pogledaj http://pedja.supurovic.net/mikrotik-raspodela-saobracaja-na-vise-internet-linkova-i-deo?lang=cir i to sva tri nastavka da bi stekao sliku o čemu se radi.
Sačuvana

blagoje
provereni korisnici
posetilac
**
Pol: Muškarac
Ime i prezime:
Blagoje Radovic
Mesto: Istočno Sarajevo
Horoskop: Ovan
Poruke: 27


« Odgovor #2 poslato: 29.05.2012. 11:11:53 »

Ja sam se tek vratio sa puta juče, tako da sam ovo tek počeo.

Meni je internet bio podešen tako da imam jednu defaul rutu i dva getveja. Ovakva kombinacija sa dvije rute i dva getveja jednostavno neće da radi!

Međutim, mislim da ne bi trebalo to da pravi probleme, jer su to rute ionako za nemarkiran saobraćaj. Dvije rute za markiran saobraćaj rade, i mogu usmjeriti internet sa bilo kog računara preko određenog WAN izlaza. Ali je problem što ne znam kako da usmjerim preko određenog WAN-a izlaz samog MikroTika, jer je ova gore skripta za mirkotik, znači meni treba da kada pokrenem skriptu na mikrotiku, da ona uvijek ide preko jednog WAN-a!

Ali je detaljno uputusvo, svaka čast.
Sačuvana
Pedja
urednik
stara kajla
*****
Pol: Muškarac
Ime i prezime:
Peđa Supurović
Mesto: Užice
Lokacija: Crna dama
Država: Srbija
FaceBook: ima
Blog: ima
Horoskop: Strelac
Poruke: 12963



WWW
« Odgovor #3 poslato: 30.05.2012. 18:15:49 »

Pošto ti hoćeš da na istom Mikrotiku pokređeš dve skripte a da one na internet idu preko različitih linkova, ne znam kako bi to moglo osim da na početku svake skripte izmeniš rutiranje tako dausmeriš saobraćaj preko željenog gejtveja a da na kraju skripte vratiš na normalno stanje.

Ako OpenDNS prima konekcije na više IP adresa, onda bi mogao da napraviš da jedna skripta uvek šalje podatke na jednu a druga na drugu IP adresu pa da koristeći te IP adrese kao destination, usmeravaš rute preko željenog gejtveja.

Na dugom dršku j emogućnost da u lokalni DNS upišeš dve adrese OpenDNS1.loc OpenDNS2.loc koej obe upućuju na stvarni ip OpenDNS servera, pa da onda u mangle da po ovim adresama razlikuješ konekcije i nekako preusmeriš rute...

Sačuvana

blagoje
provereni korisnici
posetilac
**
Pol: Muškarac
Ime i prezime:
Blagoje Radovic
Mesto: Istočno Sarajevo
Horoskop: Ovan
Poruke: 27


« Odgovor #4 poslato: 31.05.2012. 14:22:05 »

Kontaktirao sam i podršku MikroTika, i dobio negativan odgovor, jer se radi o istoj destinaciji. Znači ovako ne može.

Međutim, ja sam riješio na jedan drugačiji način (ako neko bude guglao da vidi smile))).

Moj MirkoTik ima dvije rute sa markirani saobraćaj, a to je sav saobraćaj iz LAN mreže. Ima jednu default rutu  prema ISP1, i skriptu (jednu) uvijek pokreće preko njega. Drugi skriptu sam dao drugom provajderu (ISP2), obzirom da je i kod njega mikrotik, koji služi samo da mene opslužuje internetom, ali jedino provajder ima pristup (to je inače princip u RS ne znam kako je u Srbiji...).

Znači, ja apdejtujem adresu od ISP1, a ISP2 sam sebe apdejtuje! smile))


Znam da mi je problem šta će biti kada "pukne" jedan, link, ali ću se snaći, uglavnom sam blokirao neželjeni pristup sajtovima iz LAN mreže, što je bio cilj.


Hvala mnogo u svakom slučaju.
Pozdrav
Sačuvana
Pedja
urednik
stara kajla
*****
Pol: Muškarac
Ime i prezime:
Peđa Supurović
Mesto: Užice
Lokacija: Crna dama
Država: Srbija
FaceBook: ima
Blog: ima
Horoskop: Strelac
Poruke: 12963



WWW
« Odgovor #5 poslato: 31.05.2012. 17:54:25 »

Ne važi se! To je rešenje sa dva mikrotika. smile

Sačuvana
Stranice: [1]
  Štampaj  
 
Prebaci se na:  


Pokreće MySQL Pokreće PHP Powered by SMF 1.1 RC3 | SMF © 2001-2006, Lewis Media | Imprint Ispravan XHTML 1.0! Ispravan CSS!
Stranica je napravljena za 0.091 sekundi sa 38 upita. (Pretty URLs adds 0.008s, 2q)