Dobrodošli, Gost. Molim vas prijavite se ili se registrujte.
Da niste izgubili svoj aktivacioni e-mail?
Oreska - Užice
Prijavite se sa korisničkim imenom, lozinkom i dužinom sesije
 
ARHIVA
   Početna   Pomoć Pravila Pretraga Kalendar Gallery Contact Prijavljivanje Registracija  
IZBORI: NAJFORUMAŠ I NAJFORUMAŠICA GODINE
AKCIJA: SVI UŽIČANI NA JEDNOM MESTU!
Za užičke nekomercijalne organizacije i ustanove besplatno...
Stranice: [1]
  Štampaj  
This topic has not yet been rated!
You have not rated this topic. Select a rating:
Autor Tema: RB750, 2 ISPa, problem sa PPTP VPNom  (Pročitano 2399 puta)
garson
početnik
*
Pol: Muškarac
Ime i prezime:
Vlada Urosevic
Mesto: Beograd
Poruke: 4


« poslato: 21.01.2012. 04:30:42 »

Zdravo svima.  

Dakle, imam Mtik RB750, 2 ISPa, prvi je Telekomov ADSL (dinamicka IP), sa ruterom koji radi u ruter modu, drugi je Eunet ADSL sa statickom IP, ruter radi u bridge modu.  
Za drugi link sam na Mtiku podesio pppoe client i to radi ok.  
Za podesavanja sam koristio Pedjine beleske Mikrotik: Raspodela saobraćaja na više internet linkova (II deo) i Mikrotik: Raspodela saobraćaja na više internet linkova (III deo).  

Ukratko iz beleske II deo:
za prvi link sam dodao
/ip route add dst-address=0.   0.   0.   0/0 gateway=192.   168.   1.   1 distance=2 scope=30 target-scope=10 check-gateway=ping

za drugi
/ip route add dst-address=0.   0.   0.   0/0 gateway=194.   247.   192.   254  distance=3 scope=30 target-scope=10 check-gateway=ping


Ukratko iz beleske III deo:
/ip route add dst-address=0.   0.   0.   0/0 gateway=192.   168.   1.   1  routing-mark=to_wan1 distance=5 scope=30 target-scope=10 check-gateway=ping

/ip route add dst-address=0.   0.   0.   0/0 gateway=194.   247.   192.   254  routing-mark=to_pppoe distance=5 scope=30 target-scope=10 check-gateway=ping

Dosao sam 2 liste u IP Firewall Address Lists, jer zelim da jedan deo racunara koristi prvi a ostali drugi link.  
Mangle sam podesio identicno kao u pedjinoj belesci (Označavanje dolaznih konekcija, Označavanje unapred usmerenih konekcija), Usmeravanje konekcija prema drugim kriterijumima (Ravnomerna raspodela ostalih konekcija) sam preskocio, za oznake sam koristio:
wan1_conn i pppoe_conn

itd.  

Ovo gore radi sasvim ok, DNSove sam stavio guglove javne (ugaseno Use Peer DNS).  

Takodje sam podesio PPTP server, i to radi ok kada imam samo jedan link, ali sa 2 linka se javljaju problemi.  
U principu uspem da se konektujem, dodeljene adrese su ok (poseban address pool za pptp) ali sem mtika ne vidim u "lokalnoj" mrezi nista drugo niti mogu da pristupim ruteru koji je na wan1 (192.   168.   1.   1, telekomov ruter).  
To resih dodavanjem sledeceg:
/ip route rule
add dst-address=192.   168.   100.   0/24 action=lookup table=main
add dst-address=192.   168.   1.   0/24 action=lookup table=main

(192.   168.   100.   0/24 je lokalna mreza)

Sa tim radi, vidim telekomov ruter, i ostale racunare.    Ali opet, ne radi sve kako treba:

U zavisnosti koju adresu koristim za konektovanje, u IP Firewall Connections vidim sledece:
pptp konekcija (port 1723) i gre imaju ispravne connection mark (wan1_conn ako idem preko wan1, pppoe_conn ako idem preko pppoe),
konekcije cija je source adresa ona koja mi je dodaljena imaju ispravan connection mark ako pripada nekoj od address lista,
ali ako adresa koju dobijem nije ni u jednoj listi onda nema connection mark. 
U svakom slucaju, What IP vraca adresu koja zavisi koji je gateway aktivan (onaj koji ima manji distance). 
Ako je gateway=192.   168.   1.   1 (wan1) internet je vrlo spor, neke sajtove jedna i otvara, a ukoliko je  gateway=194.   247.   192.   254 onda radi ok.   Probao sam sve moguce kombinacije (adresa na koju se konektujem, address liste). 

Zasto se ovde ne koriste rute za oznacen saobracaj?

Dakle, kako podesiti PPTP u slucaju 2 linka?
Da li je moguce da ako se konektujem preko wan1, da tada gateway bude onaj za rutu sa routing mark to_wan1 a ako idem preko pppoe da bude ona sa routing mark to_pppoe?



Takodje, interesuje me failover.    Ukoliko pukne pppoe (desavalo se) automatski se prebaci na wan1, ali obrnuto ne vazi (sem ako se recimo ugasi wan1 ruter ili izvuce mrezni kabl koji ide iz njega).    Jasno mi je i zasto, ali kako podesiti da failover radi ako pukne ADSL na wan1?


Izvinjavam se sto sam se ovoliko raspisao i hvala unapred.      smile
 


« Poslednja izmena: 22.01.2012. 01:06:10 garson » Sačuvana
garson
početnik
*
Pol: Muškarac
Ime i prezime:
Vlada Urosevic
Mesto: Beograd
Poruke: 4


« Odgovor #1 poslato: 22.01.2012. 02:00:12 »

Nesto sam razmisljao, posto kad se korisnik konektuje VPNom, kreira se novi interfejs za njega. Pretpostavljam da su potrebna dodatna podesavanja u IP Firewall Mangle, jer se ova sto sam dodao ne odnose na PPTP interfejs.   icon2
Sačuvana
Pedja
urednik
stara kajla
*****
Pol: Muškarac
Ime i prezime:
Peđa Supurović
Mesto: Užice
Lokacija: Crna dama
Država: Srbija
FaceBook: ima
Blog: ima
Horoskop: Strelac
Poruke: 12963



WWW
« Odgovor #2 poslato: 23.01.2012. 14:12:54 »

Kada radis sa više interfejsa uvek se drži pravila: jedan WAN i više LAN ili više WAN i jedan LAN. Nikako nemoj na istom ruteru imati više WAN  iviše LAN jer to mnogo komplikuje podešavanje.

PPP konekcije ti u principu dođu svaka kao novi LAN interfejs.
Sačuvana

garson
početnik
*
Pol: Muškarac
Ime i prezime:
Vlada Urosevic
Mesto: Beograd
Poruke: 4


« Odgovor #3 poslato: 24.01.2012. 10:57:44 »

Pedjo, hvala na odgovoru.

Ako je tako za sada ne bih petljao.  smile Ali bih u nekom trenutku voleo da probam i tako nesto.  Cheesy

Ono sto me ovde i dalje buni, zasto vpn lepo radi preko jedne rute a preko druge neke sajtove otvara neke nece?

Takodje me interesuje ideja, kako da resim failover do kraja? U slucaju pppoe to radi, ali u slucaju WANa mi treba drugo resenje, kontam neka skripta koja pinguje recimo google.com ili tako nesto?



Sačuvana
Pedja
urednik
stara kajla
*****
Pol: Muškarac
Ime i prezime:
Peđa Supurović
Mesto: Užice
Lokacija: Crna dama
Država: Srbija
FaceBook: ima
Blog: ima
Horoskop: Strelac
Poruke: 12963



WWW
« Odgovor #4 poslato: 24.01.2012. 14:35:52 »

Prvi link ti je default gateway za sve konekcije za koje ne zna kako drugačije da ih rutira, pa verovatno tad sve konekcije odu preko njega.

Opet, ako se desava da neke konekciej rade a neke ne onda je vrlo verovatno problem sa MTU. Ako je MTU preveliki onda neki paketi, koji su duzi ne mogu preneti pa konekcija ne radi.

Sačuvana

garson
početnik
*
Pol: Muškarac
Ime i prezime:
Vlada Urosevic
Mesto: Beograd
Poruke: 4


« Odgovor #5 poslato: 24.01.2012. 23:49:03 »

Da, kad je prvi default desava se opisano. Palo mi je na pamet da je MTU problem ali kako to resiti?
Sačuvana
cvijicm
početnik
*
Pol: Muškarac
Ime i prezime:
Milenko Cvijić
Mesto: Subotica
Država: Subotica
Poruke: 4


« Odgovor #6 poslato: 15.05.2012. 23:57:43 »

Hvala ti, svaka čast.Našao sam link po kom ću da vršim testiranje.
 http://wiki.mikrotik.com/wiki/Open_source_caching_server
Da li možeš da pojasniš http-mark?Kad se i sa kojim ciljem koristi?Video sam ga u podešavanju ip route i kod nat pravila.
E, da, pročitao sam da postoji specijalan slučaj kad IP ima subnet 254.Dakle, nema mrežne adrese,a ni, broadcast adrese.Kako to funkcioniše?
Veliki pozdrav!
Sačuvana
Pedja
urednik
stara kajla
*****
Pol: Muškarac
Ime i prezime:
Peđa Supurović
Mesto: Užice
Lokacija: Crna dama
Država: Srbija
FaceBook: ima
Blog: ima
Horoskop: Strelac
Poruke: 12963



WWW
« Odgovor #7 poslato: 16.05.2012. 11:28:12 »

Ne znam gde si video http-mark pa ne mogu ništa o tome da tikažem. Meni izgleda kao ime koje je neko izabrao za pravilo kojim oznacava http konekcije.

Mikrotik moze da skrati IP masku tako da se mreža sastoji od samo dve IP adrese, bez broadcast i mrežne adrese. To ipak radi samo u kontrolisanim uslovima i nije po standardu. Nemoj to koristiti, jer će ti kad tad napraviti glavobolju.

Što se proksiaj tiče, jesi li siguran da ti to treba. Proxy je previše zahtevan i u konfiguraisanju i u hardveru a dobitak do nejga nije veliki pogotovo sada kada je većina sadržaja na webu dinamičnai ne može se keširati (bolej rečeno, nema smisla keširati).

Sačuvana

Stranice: [1]
  Štampaj  
 
Prebaci se na:  


Pokreće MySQL Pokreće PHP Powered by SMF 1.1 RC3 | SMF © 2001-2006, Lewis Media | Imprint Ispravan XHTML 1.0! Ispravan CSS!
Stranica je napravljena za 0.316 sekundi sa 39 upita. (Pretty URLs adds 0.011s, 2q)