Dobrodošli, Gost. Molim vas prijavite se ili se registrujte.
Da niste izgubili svoj aktivacioni e-mail?
Oreska - Užice
Prijavite se sa korisničkim imenom, lozinkom i dužinom sesije
 
ARHIVA
   Početna   Pomoć Pravila Pretraga Kalendar Gallery Contact Prijavljivanje Registracija  
IZBORI: NAJFORUMAŠ I NAJFORUMAŠICA GODINE
AKCIJA: SVI UŽIČANI NA JEDNOM MESTU!
Za užičke nekomercijalne organizacije i ustanove besplatno...
Stranice: [1]
  Štampaj  
This topic has not yet been rated!
You have not rated this topic. Select a rating:
Autor Tema: dali je ovo neko probao i na kom principu radi?  (Pročitano 4196 puta)
bensedin
početnik
*
Pol: Muškarac
Ime i prezime:
Dragan Milosavljevic
Mesto: Aleksinac
Država: Srbija
Poruke: 6


« poslato: 21.08.2011. 07:38:39 »

Zanima me dali je neko koristio 2 interneta u isto vreme -sa 2 lan kartice i kako mogu da jednu konekciju zaduzim samo sa download a drugu konekciju recimo za online igre?
Sačuvana
Pedja
urednik
stara kajla
*****
Pol: Muškarac
Ime i prezime:
Peđa Supurović
Mesto: Užice
Lokacija: Crna dama
Država: Srbija
FaceBook: ima
Blog: ima
Horoskop: Strelac
Poruke: 12951



WWW
« Odgovor #1 poslato: 22.08.2011. 15:29:53 »

Teba ti ruter koji omogucava tako nesto, na primer Mikrotik.
Sačuvana

bensedin
početnik
*
Pol: Muškarac
Ime i prezime:
Dragan Milosavljevic
Mesto: Aleksinac
Država: Srbija
Poruke: 6


« Odgovor #2 poslato: 23.08.2011. 00:37:48 »

Ma dobro to nego kako se to radi ? Koji protokoli treba da se omoguce na jednom Lan izlazu a koji na drugom ako se to uopste tako radi i dali se te konekcije sabiraju ili svaka radi sasebno za sebe?
Sačuvana
Pedja
urednik
stara kajla
*****
Pol: Muškarac
Ime i prezime:
Peđa Supurović
Mesto: Užice
Lokacija: Crna dama
Država: Srbija
FaceBook: ima
Blog: ima
Horoskop: Strelac
Poruke: 12951



WWW
« Odgovor #3 poslato: 23.08.2011. 13:37:40 »

Ne treba nikakav poseban protokol, podešava se rutiranje tako da saobraćaj za neke protokole ide na jedan wan a za druge na drugi.
Sačuvana

nik007
posetilac
**
Pol: Muškarac
Ime i prezime:
Nikola Petkovic
Mesto: Lebane
Država: Srbija
Poruke: 30


« Odgovor #4 poslato: 11.06.2015. 20:42:47 »

Potrebno je odraditi load balansing ako se ne varam Cheesy

evo tutorijala sa sveta kompijutera

Pod terminom load balancing obično se podrazumeva deljenje internet saobraćaja na dve konekcije. Evo kako se to može izvesti pomoću jeftinijih Mikrotikovih rutera

„Bio sam najbolji balanser, i to kod bata Alimpija!”

Prle, operativac pokreta otpora u seriji „Povratak otpisanih”

(Klik za uvećanje: JPEG, 57 KB)
Osnovna konfiguracija lokalne mreže za load balancing
Zanimljiva, a u nekim situacijama i vrlo korisna mogućnost pri konfigurisanju manjih i srednjih lokalnih mreža jeste korišćenje dve internet konekcije. Ukoliko je jedna konekcija preopterećena, postoji mogućnost da se opterećenje ravnomerno podeli (izbalansira) na obe konekcije. Rezervna konekcija korisna je i u slučaju da dođe do prekida primarne.

Na našem tržištu moguće je naći jeftine rutere, koji uz primarnu internet konekciju podržavaju i rezervnu. Nažalost, sekundarna konekcija najčešće može biti samo ona koja se ostvaruje preko 3G veze. Tako je u TP-Linkovim modelima TL-MR3220 i TL-MR3420, koji, osim konekcijom povezanom na WAN konektor, barataju i 3G USB modemima povezanim na USB konektor, moguće odrediti koja je primarna a koja rezervna. U ovim ruterima je moguće, nakon podešavanja 3G i WAN konekcije, u meniju Network Internet Access odabrati primarnu i rezervnu konekciju. To rešenje je prihvatljivo samo u slučaju kada nije potrebno istovremeno korišćenje obe konekcije i kada se rezervna konekcija može ostvariti 3G vezom.

(Klik za uvećanje: JPEG, 70 KB)
Početak podešavanja rutera; standardne postavke nećemo koristiti
Kada se koriste dve „klasične” veze (ADSL, internet preko kablovske televizije, žična veza u zgradi poslovnog ili stambenog prostora ili konekcija bežičnog operatera), potreban je mrežni ruter sa dva WAN konektora i podešavanje koje će obezbediti ravnomerno (izbalansirano) korišćenje dve konekcije. Ruteri nižeg i srednjeg cenovnog ranga sa operativnim sistemom Mikrotik (recimo, modeli Routerboard RB750 i RB750G) pružaju veliki broj osnovnih i naprednih tehnika rutiranja, a load balancing je jedna od njih.

Pojam load balancing ima više značenja, ali se u terminologiji vezanoj za podešavanje SOHO (small office/home office) rutera obično misli na ravnomerno korišćenje dve ili više konekcija. U marketinškim karakteristikama Mikrotikovih rutera nalazi se i opcija Load balancing, koju ne možemo tek tako uključiti i za čije je aktiviranje potrebno obezbediti posebne uslove. Provereni scenario u kojem balansiranje radi jeste sa već NAT-ovanim konekcijama.

Kako podesiti

(Klik za uvećanje: JPEG, 105 KB)
Unošenje komandi za konfigurisanje u prozoru terminala
Recimo da jednu konekciju ostvarujemo ADSL vezom, da je LAN adresa ADSL rutera 192.168.1.1 i on povezanim računarima dodeljuje adresu iz opsega 192.168.1.2–192.168.1.254. Druga konekcija se, recimo, ostvaruje preko operatera kablovske televizije kombinacijom modema i rutera čija je LAN adresa 192.168.2.1, a povezanim računarima dodeljuje adrese iz opsega 192.168.2.2–192.168.2.254. LAN port sa jednog rutera povezaćemo sa LAN portom broj 1, a drugog sa portom broj 2 na Mikrotikovom ruteru. Mikrotikov LAN konektor broj 3 povezaćemo sa mrežnim adapterom u računaru, kojem ćemo ručno dodeliti IP adresu (recimo, 192.168.88.10) u folderu Network Connections, koji se nalazi u Control Panelu, desnim klikom na Local Area Connection i odabiranjem opcije Properties. U meniju General odabraćemo Internet Protocol (TCP/IP) i umesto na Obtain an IP adress automatically kliknuti na Use the following IP address. U meniju podešavanja mrežnog adaptera računar će nam u polju Subnet mask sugerisati vrednost 255.255.255.0, što ćemo prihvatiti. Mikrotiku se pristupa preko browsera kucanjem adrese 192.168.88.1 (što je podrazumevana adresa). Sa prikazane web strane treba preuzeti grafički program Winbox, kojim se pristupa svim opcijama Mikrotika. Alternativni način je preuzimanje Winboxa sa interneta, pronalaženje MAC adrese Mikrotik rutera (klikom na ekranski taster sa tri tačke, levo od dugmeta ’Connect’ u Winboxu). Nakon otvaranja grafičkog prikaza rutera, potrebno je obrisati specifična podešavanja, koje proizvođač postavlja kako bi olakšao povezivanje kod klasične raspodele internet veze, što nam za podešavanje load balancinga nije potrebno. Prilikom prvog povezivanja na Mikrotik pojaviće se prozor RouterOS Default Configuration sa opcijom Remove Configuration. Ukoliko smo se ranije već konektovali na ruter, do te opcije ćemo doći startovanjem terminala klikom na ’New Terminal’, kucanjem komande setup i izborom opcije r. Nakon automatskog restartovanja rutera, pristupićemo mu preko MAC adrese u Winboxu, posle čega će nam se pojaviti prozor sa opcijom Remove Configuration. Nakon još jednog automatskog restartovanja spremni smo za podešavanje „od početka”. U meniju Interface promenićemo imena interfejsima ether1 u wlan1, ether2 u wlan2 i ether3 u local.

Podešavanje „od nule”

Otvorićemo prozor terminala i unositi jednu po jednu komandu:

/ ip address

add address=192.168.88.1/24 network=192.168.88.0 broadcast=192.168.88.255 interface=local

add address=192.168.1.2/24 network=192.168.1.0 broadcast=192.168.1.255 interface=wlan1

add address=192.168.2.2/24 network=192.168.2.0 broadcast=192.168.2.255 interface=wlan2

/ ip route

add dst-address=0.0.0.0/0 gateway=192.168.1.1,192.168.2.1 check-gateway=ping

/ ip firewall nat

add chain=srcnat out-interface=wlan1 action=masquerade

add chain=srcnat out-interface=wlan2 action=masquerade

/ ip firewall mangle

add chain=input in-interface=wlan1 action=mark-connection new-connection-mark=wlan1_conn

add chain=input in-interface=wlan2 action=mark-connection new-connection-mark=wlan2_conn

add chain=output connection-mark=wlan1_conn action=mark-routing new-routing-mark=to_wlan1

add chain=output connection-mark=wlan1_conn action=mark-routing new-routing-mark=to_wlan2

/ ip route

add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_wlan1

add dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=to_wlan2

(Klik za uvećanje: JPEG, 56 KB)
Uključivanje DHCP-a za lokalnu mrežu
U navedenom primeru podvučene su adrese i delovi adresa koje je potrebno promeniti ukoliko su adrese rutera koji dovode internet kod vas drugačije.

Ako se brzina internet konekcija razlikuje, pa, na primer, jedan provajder obezbeđuje 16 Mbit/s a drugi 4 Mbit/s, komandu iz prethodnog primera

/ ip route

add dst-address=0.0.0.0/0 gateway=192.168.1.1,192.168.2.1 check-gateway=ping

(Klik za uvećanje: JPEG, 69 KB)
Prikaz konfiguracije podešene za load balancing
treba promeniti tako da se vrednost za gateway brže konekcije ponavlja srazmerno odnosu brzina. U sledećem primeru internet konekcija sa dolaznog rutera adrese 192.168.2.1 brža je četiri puta od one sa rutera adrese 192.168.1.1:

/ ip route

add dst-address=0.0.0.0/0 gateway=192.168.1.1,192.168.2.1,192.168.2.1,192.168.2.1,192.168.2.1, check-gateway=ping

Sledeća stavka koju je potrebno podesiti jeste adresa DNS servera koji će koristiti Mikrotikov ruter. Kako naizmenično koristimo konekcije različitih provajdera koji najverovatnije ne dozvoljavaju da se njihov DNS koristi preko drugih provajdera, potrebno je koristiti neki od javnih DNS servisa. U meniju IP, kod stavke DNS, odabraćemo karticu Static i dugme Settings. U ovom primeru koristićemo adrese servisa OpenDNS 208.67.220.220 i 208.67.222.222, pri čemu ćemo čekirati opciju Allow Remote Requests. To možemo uraditi i u prozoru terminala unoseći naredbu

/ip dns set allow-remote-requests=yes \primary-dns=208.67.220.220 secondary-dns=208.67.222.222

ili

/ip dns set allow-remote-requests=yes servers=208.67.220.220,208.67.222.222

za novije verzije Mikrotika.

I za kraj...

Preostalo je još podešavanje DHCP servera kako na svakom računaru u lokalnoj mreži ne biste morali odvojeno da podešavate parametre konekcije. U meniju IP odabraćemo stavku DHCP server i tasterom ’DHCP Setup’ pokrenuti čarobnjak (wizard) za podešavanja. Za DHCP Server Interface odabraćemo local, potvrdićemo DHCP Address Space: 192.168.88.0/24, kao i 192.168.88.1 za Gateway for DHCP Network. Za Address to Give Out čarobnjak će ponuditi opseg 192.168.88.2–192.168.88.254, što ćemo potvrditi, kao i adrese 208.67.220.220 i 208.67.222.222 za Select DNS servers. Potvrdićemo i vrednost 3d 00:00:00 za „Lease Time”. Ukoliko želimo da dodatne računare povežemo na konektore 4 i 5, moraćemo dodati i bridž, u koji ćemo dodati interfejse local, ether4 i ether5. Bridž ćemo kreirati u meniju Bridge odabiranjem polja ’+’ i ’OK’, nakon čega ćemo odabrati karticu Ports i na polju ’+’ dodati interfejse. U ovom slučaju ćemo kod podešavanja DHCP servera umesto interfejsa local odabrati kreirani bridž interfejs (bridge1). Na kraju je potrebno vratiti opciju automatskog podešavanja IP adrese mrežnog interfejsa u računaru s kog smo pristupali Mikrotiku. Sada je Mikrotikov ruter spreman za raspoređivanje saobraćaja na dve internet konekcije, a ukoliko dođe do prekida jedne, automatski će nastaviti rad sa drugom.

• • •

Na kraju treba napomenuti to da je ovaj primer dat kao osnova, primenljiva na ruterima i računarima sa instaliranim operativnim sistemom Mikrotik. Ovo je ujedno i rešenje koje se lako može modifikovati – ako, na primer, koristimo računar sa Mikrotik OS-om, možemo mu ubaciti WiFi karticu i pretvoriti ga u bežični ruter. Moguće je i eliminisati postojeće dodatne rutere kod nekih tipova dolaznih internet konekcija (recimo, kod konekcije preko kablovske televizije), ali je tada potrebno od provajdera dobiti statičku IP adresu i parametre konekcije, što u našim uslovima najčešće predstavlja nepremostivu teškoću.
Sačuvana
Stranice: [1]
  Štampaj  
 
Prebaci se na:  


Pokreće MySQL Pokreće PHP Powered by SMF 1.1 RC3 | SMF © 2001-2006, Lewis Media | Imprint Ispravan XHTML 1.0! Ispravan CSS!
Stranica je napravljena za 0.155 sekundi sa 37 upita. (Pretty URLs adds 0.009s, 2q)