https://forum.uzice.net Oreska - Užice : Wireless Užice - Užice bez žice - Mikrotik routerOS downgrade - forum Uzicana - mesta: Uzice, Pozega, Arilje, Ivanjica, Kosjeric, Bajina Basta, Priboj, Prijepolje, Zlatibor - Cajetina, Nova Varos, Sjenica
Dobrodošli, Gost. Molim vas prijavite se ili se registrujte.
Da niste izgubili svoj aktivacioni e-mail?
Oreska - Užice
Prijavite se sa korisničkim imenom, lozinkom i dužinom sesije
 
ARHIVA
   Početna   Pomoć Pravila Pretraga Kalendar Gallery Contact Prijavljivanje Registracija  
IZBORI: NAJFORUMAŠ I NAJFORUMAŠICA GODINE
AKCIJA: SVI UŽIČANI NA JEDNOM MESTU!
Za užičke nekomercijalne organizacije i ustanove besplatno...
Stranice: [1]
  Štampaj  
This topic has not yet been rated!
You have not rated this topic. Select a rating:
Autor Tema: Mikrotik routerOS downgrade  (Pročitano 4414 puta)
dragan025
početnik
*
Pol: Muškarac
Ime i prezime:
Dragan Jovanovic
Mesto: Odzaci
Država: Srbija
Poruke: 12


« poslato: 04.05.2012. 14:58:42 »

Pozdrav forumasi!

Evo ovako, nikako mi neuspeva downgrade OS-a. Imao sam 2.9.51 i nedavno, zbog nekih bagova sa bridge-om i wireless-om sam resio da instalisem 3.3(inace moj rouerboard je upgradable na max 3.x sa L4 licencom) i sada imam problema otkad sam presao na 3.3. Svako malo mi se restartuje router, zatim cesto se diskonktuje sa AP-a, CPU znatno vise opterecen nego ranije...i uzasno me nervira. Menjao sam 3 napajanja od 18-28V i situacija je ista.
Pokusao sam da ubacim 2.9.51.npk preko wnbox-a u file i komandom `/system package downgrade - ponudi mi da li hocu da se restartuje, kazem OK`nece, ostane ponovo 3.3 zatim i 2.7.20.npk, isto nece  i dalje ostao OS 3.3

Ako moze mala pomoc(dok ga nisam skinuo sa krova sacmaricom), kako da ga downgradujem?
Hvala unapred!
Sačuvana
lujics
posetilac
**
Ime i prezime:
Sinisa Lujic
Mesto: Subotica
Država: Srbija
Poruke: 42


« Odgovor #1 poslato: 05.05.2012. 08:46:38 »

Pozdrav.
Ja  bi ti predlozio da uradis upgrade na trenutno aktuelnu verziju 5.15.
Iako ti u sys-licence pise da imas prava do 3.x, svaki router board ima prava na najnoviju verizu RouterOS-a.
Uradi sledece, upgrade-uj sistem na 3.30 (ali obavezno 3.30), idi u system->licence, imaces tamo opciju "update licence key", router ce ti sam odraiti update na novu vrstu licence sa mikrotikovog sajta (NAPOMENA: moras imati internet konekciju na racunaru sa kog radis update licence), pitace te za restart, potvrdi, kada se router ponovo podigne, upgrade-uj ga na 5.15.

Zasto ti preporucujem upgrade? Mnogo stvari je napredovalo i usavrseno od verzije 2.x i 3.x, mongo je bolje iskoriscenje resursa routera sa novijim RouterOS-vima, wireless je napravio znatne pomake u kvalitetu, jednostavno novo je novo. Nazalost ti si bas upgrade-ovao router na najlosji RouterOS iz serije 3.x.

Pozdrav
Sačuvana
Pedja
urednik
stara kajla
*****
Pol: Muškarac
Ime i prezime:
Peđa Supurović
Mesto: Užice
Lokacija: Crna dama
Država: Srbija
FaceBook: ima
Blog: ima
Horoskop: Strelac
Poruke: 12963



WWW
« Odgovor #2 poslato: 05.05.2012. 11:26:04 »

Možda nisi uzeo npk za odgovarajuću platformu. Različiti RB koriste različite čipsetove pa je potrebno da mu staviš npk koji je namnejen baš za odgovarajući čipset.

I ja bih preporučio da uradiš upgrade na noviju verziju, ali ne baš 5.15. To jejoš uvek sveže a već se nagomilalo pritužbi na probleme sa njim. Verzija 5.4 je prilično dobra.
Sačuvana

dragan025
početnik
*
Pol: Muškarac
Ime i prezime:
Dragan Jovanovic
Mesto: Odzaci
Država: Srbija
Poruke: 12


« Odgovor #3 poslato: 05.05.2012. 11:30:45 »

Sinoc sam uspeo da vratim na 2.9.51, ocigledno sam pokusavao sa krivim verzijama tj. ne za moj RB, inace RB100. Sada sam hteo da upgrade na 5.15.
Prvo sam isao na 3.3 i sve je bilo ok, zatim update key i to mi je proslo i pisalo da mogu ici do 6.xx verzije u licenci. Skinuo sam za moj board sa Mikrotik sajta verziju 5.15.npk i posle update kljuca, ubacio u file i reboot router i vise se ne dize, cekao nekih 15 min i nista, iskljucio napojni i ponovo ukljucio i dalje ne mogu da mu pristupim. Skinuo sam ga sa krova i cujem da odradi onaj prvi beep, ali drugog, onaj dupli ni traga ni glasa, hm. Da li ima sanse da pristupim nekako NAND disku, posto preko winbox-a, naravno, nece tj. ne vidim MAC jer nije ni podigao sistem. Da li se ista moze uraditi? Napominjem da je os 5.15 uredno skinutu i ubacen, dakle nista nije prekidano i sl. Pomagajte, ako Boga znate. Pozz! E da, pokusao i reset preko dzampera i onaj taster i jok.

P.S. Mada i ovaj DialUp nije los:)

Edit, ne videh Pedjin odgovor dok sam se mucio sa DialUp-om:)
Upravo to Pedja, iz besa sam skidao milion razlicitih i od 20-ak nijedan sto je meni odgovarao. Tek sam, malo citajuci, skontao da mi treba `-ns.npk` i skinuo njega i sve je proslo OK. Ali evo desi mi se ovo sada sa najnovijim, djavo ga odneo, a bas sam se ponadao da ce sve lepo proci, a ono mrk. Imate li neku ideju i da li je u opste moguce sada nesto odraditi.
Pozdrav i hvala Vam obojici!

Edit: Evo proslo je nekih 20 min. i jos se ne budi, tj nema drugog duplog beep-a niti ga vidim u winbox-u kako bih mu pristupio:(
Sačuvana
lujics
posetilac
**
Ime i prezime:
Sinisa Lujic
Mesto: Subotica
Država: Srbija
Poruke: 42


« Odgovor #4 poslato: 06.05.2012. 11:15:53 »

Postoje dva nacina za resavanje.

1. Ako ti je dobro intaliran paket, onda samo oradi hard reset na ploci, imas jedan "jumper" gore desno. Zatvori ga upali mikrotik, ostavi ga jedno 2 min, ponovo otvori, i probaj da pokernes.

2. Treba ti serial null modem kabel, i onda konzola, sve ti je objasnjeno ovde:

http://wiki.mikrotik.com/wiki/Manual:Netinstall
Sačuvana
dragan025
početnik
*
Pol: Muškarac
Ime i prezime:
Dragan Jovanovic
Mesto: Odzaci
Država: Srbija
Poruke: 12


« Odgovor #5 poslato: 06.05.2012. 20:43:40 »

Probao sam reset preko dzampera (kao sto sam i napisao gore) i ne pomaze. Jedino mi ostaje preko Netinstall-a, ali trenutno nemam serial kabel pa cu pokusati cim ga nabavim i javljam ishod. Hvala!

Da li moze ovaj kabel?
http://www.kupindo.com/Kablovi/9788130_Roline-Serial-link-RS232-kabl-F-F-1-8m-modem-reciver-

Ili koji od ovih na brzaka da napravim, jer imam konektore, samo ne znam koji da pravim. Evo link:

http://www.lammertbies.nl/comm/info/RS-232_null_modem.html

Da li bi pasao najjednostavniji Null modem without handshaking?
« Poslednja izmena: 06.05.2012. 21:07:27 dragan025 » Sačuvana
Pedja
urednik
stara kajla
*****
Pol: Muškarac
Ime i prezime:
Peđa Supurović
Mesto: Užice
Lokacija: Crna dama
Država: Srbija
FaceBook: ima
Blog: ima
Horoskop: Strelac
Poruke: 12963



WWW
« Odgovor #6 poslato: 07.05.2012. 08:32:49 »

Ovde imas tačnu specifikaciju za kabal: http://wiki.mikrotik.com/wiki/Serial_Console
Sačuvana

dragan025
početnik
*
Pol: Muškarac
Ime i prezime:
Dragan Jovanovic
Mesto: Odzaci
Država: Srbija
Poruke: 12


« Odgovor #7 poslato: 07.05.2012. 11:46:39 »

Naravno, jedan konektor nadjoh, a drugog nema pa nema, a imao sam ih nekoliko:)

Nasao sam na oglasu RS232/db9, da li moze taj? Covek koji prodaje ima samo ovu informaciju.
Sačuvana
Pedja
urednik
stara kajla
*****
Pol: Muškarac
Ime i prezime:
Peđa Supurović
Mesto: Užice
Lokacija: Crna dama
Država: Srbija
FaceBook: ima
Blog: ima
Horoskop: Strelac
Poruke: 12963



WWW
« Odgovor #8 poslato: 09.05.2012. 08:41:04 »

Pogledaj u ExeShop-u (imas gore baner sa linkom). Oni imaju gotove kablove.
Sačuvana

dragan025
početnik
*
Pol: Muškarac
Ime i prezime:
Dragan Jovanovic
Mesto: Odzaci
Država: Srbija
Poruke: 12


« Odgovor #9 poslato: 09.05.2012. 14:49:02 »

Uzeo sam kabel i preko h. terminala usao u BIOS rutera i podesio da butuje preko interneta i ne vidim board u netinstall-u. Samo vrti ovo:
RouterBOOT booter 2.7

RouterBoard 133

CPU frequency: 175 MHz
  Memory size:  32 MB

Press any key within 2 seconds to enter setup..
trying bootp protocol...........

Inace kada ga bootujem izgleda ovako u terminalu:
RouterBOOT booter 2.7

RouterBoard 133

CPU frequency: 175 MHz
  Memory size:  32 MB

Press any key within 2 seconds to enter setup..
loading kernel from nand... OK
setting up elf image... OK
jumping to kernel code
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

I jos nesto, da li bi mi pomoglo da formatiram NAND i da li bi sacvuvao licencu. Key srecom imam bekapovan, ali da li bi mi i dalje vazio ako odradim format i instalisem nanovo OS?
Ne znam sta mi je ciniti i zasto ne vidim board preko netinstall-a?
Sačuvana
dragan025
početnik
*
Pol: Muškarac
Ime i prezime:
Dragan Jovanovic
Mesto: Odzaci
Država: Srbija
Poruke: 12


« Odgovor #10 poslato: 09.05.2012. 16:44:33 »

Evo formatirao sam NAND i opet ne mogu da mu pristupim preko netinstall-a:

Press any key within 2 seconds to enter setup..
trying bootp protocol.......... OK
Got IP address: 192.168.1.2
resolved mac address 00:E0:4C:9E:26:A7
transfer started .......................... transfer ok, time=2.24s
setting up elf image... OK
jumping to kernel code
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

Kako resiti ovo? Imali neko ideju, jer ne mogu nista sa neta da iskopam?
Hvalja ljudi unapred.

EDIT: Uspelo! Problem je bio u verziji netinstall-a, umesto 5.15, probao sa 3.3 i sve proradio. Ubacio routerOS 5.13 i sljaka. Dobro je sto je ostala licenca.smile

Hvala Vam! Pozdrav!
« Poslednja izmena: 09.05.2012. 17:50:13 dragan025 » Sačuvana
Stranice: [1]
  Štampaj  
 
Prebaci se na:  


Pokreće MySQL Pokreće PHP Powered by SMF 1.1 RC3 | SMF © 2001-2006, Lewis Media | Imprint Ispravan XHTML 1.0! Ispravan CSS!
Stranica je napravljena za 0.171 sekundi sa 38 upita. (Pretty URLs adds 0.008s, 2q)